15-16 lost activation

Tried to upgrade 15-16 and it has lost my activation.

Used the upgrade module, and it finished step 1 and then wouldn’t start step 2.

Rebooted because GUI was non-functional and it says I need to activate.

tried to activate from CLI and it says:

Running /var/www/html/admin/modules/sysadmin/bin/activate_existing xxxxxxxx
Asking for deployment xxxxxxxx…eth0: error fetching interface information: Device not found
Error!
Unable to get Machine ID

[[email protected] ~]# fwconsole sysadmin activate [email protected]
Attempting to activate against email address ‘[email protected]
Running /var/www/html/admin/modules/sysadmin/bin/register_new [email protected]
Validating email…OK!
Asking for deployment ID…eth0: error fetching interface information: Device not found
Exception: Unable to get Machine ID in file /var/www/html/admin/modules/sysadmin/Reg.class.php on line 164
Stack trace:

  1. Exception->() /var/www/html/admin/modules/sysadmin/Reg.class.php:164
  2. FreePBX\modules\Sysadmin\Reg->getDeploymentID() /var/www/html/admin/modules/sysadmin/bin/register_new:43

I do know that my interface to the outside world is eno1 not eth0

15 uses zend, 16 uses ioncube so there will be some licensing edge cases I am sure.

If you do ip addr do you have an eth0?
I certainly hope they didn’t hard code something :-/

In any case 99% sure you will need to open a support ticket.

[[email protected] ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group defaul t qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp0s25: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default q len 1000
link/ether 0c:c4:7a:78:6b:47 brd ff:ff:ff:ff:ff:ff
3: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP gr oup default qlen 1000
link/ether 0c:c4:7a:78:6b:46 brd ff:ff:ff:ff:ff:ff
inet 10.10.165.2/24 brd 10.10.165.255 scope global eno1
valid_lft forever preferred_lft forever
inet6 fe80::ec4:7aff:fe78:6b46/64 scope link
valid_lft forever preferred_lft forever
4: w1g1: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 8 qdisc noqueue state UNKNOWN group default qlen 100
link/ppp

Lol it’s that renamed interface stuff, so no eth0 or eth1 just eno1

I miss Redhat 5… 6.1 ruined it all :slight_smile:

Can’t open support ticket without purchasing $395.00 2hr support block

Billing/licensing dept says I HAVE to open support ticket not licensing ticket

Is this a FreePBX Distro system?

Yes, sorry, I didn’t put that since I posted this in the FreePBX Instalation/Upgrade section

It is a FreePBX appliance purchased before the transition to Sangoma

Everything was working well about 2 days ago before a module was auto updated due to security, but that could be a red herring.

I saw the upgrade went Beta->GA and decided to do it.

Purchased extensions to licenses of Extension Routes and Endpoint manager prior to the upgrade, and now it looks like the ioncube activation process is somehow hard coded to eth0 as jfinstrom guessed above.

Also in the portal it says my activation is locked due to too many attempts, but I have never reset my activation to my knowledge. Maybe once VERY early when we had a hardware issue with the appliance.

What linux distribution are you running?

 cat /etc/schmooze/pbx-version

12.7.8-2109-3.sng7

That distro question got me thinking maybe there is some broken part of the install, since i have upgraded the distro several times over the years so I ran:

[[email protected] asterisk]# yum list updates
Loaded plugins: fastestmirror, versionlock
Repository sng-sng7php74 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
sng-base | 3.6 kB 00:00
sng-epel | 2.9 kB 00:00
sng-extras | 2.9 kB 00:00
sng-pkgs | 3.4 kB 00:00
sng-sng7php74 | 3.4 kB 00:00
sng-updates | 2.9 kB 00:00
Updated Packages
sangoma-logos.noarch 70.0.7-2.sng7 sng-sng7php74
[[email protected] asterisk]# yum upgrade
Loaded plugins: fastestmirror, versionlock
Repository sng-sng7php74 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
Resolving Dependencies
–> Running transaction check
—> Package sangoma-logos.noarch 0:70.0.6-6.sng7 will be updated
—> Package sangoma-logos.noarch 0:70.0.7-2.sng7 will be an update
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size

Updating:
sangoma-logos noarch 70.0.7-2.sng7 sng-sng7php74 21 M

Transaction Summary

Upgrade 1 Package

Total download size: 21 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
sangoma-logos-70.0.7-2.sng7.noarch.rpm | 21 MB 00:02
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Updating : sangoma-logos-70.0.7-2.sng7.noarch 1/2
Cleanup : sangoma-logos-70.0.6-6.sng7.noarch 2/2
Verifying : sangoma-logos-70.0.7-2.sng7.noarch 1/2
Verifying : sangoma-logos-70.0.6-6.sng7.noarch 2/2

Updated:
sangoma-logos.noarch 0:70.0.7-2.sng7

Complete!
[[email protected] asterisk]#

This did not fix. I think it is something in the new activation method that is hardcoded to look for MAC address on eth0 and my machine doesn’t have an “eth0” (technically it does but that NIC is on the mobo and is disabled).

ip link add name eth0 type dummy
ip link set eth0 address be:ef:be:ef:be:ef

does that work?

[[email protected] ~]# ip link add name eth0 type dummy
[[email protected] ~]# ip link set eth0 address be:ef:be:ef:be:ef
[[email protected] ~]# fwconsole sa a xxxxxxxx Attempting to activate against deployment ‘xxxxxxxx’
Running /var/www/html/admin/modules/sysadmin/bin/activate_existing xxxxxxxx
Asking for deployment xxxxxxxx…Success!
Array
(
[Hardware-Locked] => Yes
[Produced-By] => Schmooze Communications
[Product-Name] => PBXact
[Registered-To] => xxxxxxxx
[backup_password] => **********
[backup_username] => XXXXXXXX
[branding] => FreePBXDistro
[deploy_type] => OSS
[deployment_id] => xxxxxxxx
[deploymentid] => xxxxxxxx
[distributor] => No
[epm_exp] => 2039-04-18
[extroute_exp] => 2039-04-18
[global_lic_exp] => 2039-01-26
[license_version] => 2
[sysadmin_exp] => 2039-04-18
[updates] => ********
[vpn_ip] => x.x.x.x
[Expires] => 29-Jan-2030
[machineid] => ********
[xxxxxxxx] =>
[deployment_name] => ********
)
Setting permissions…
Restarting httpd…
Done

So yes, they have eth0 hardcoded somewhere.

Thank you so much for the help.

I have a tech support request with the activation team that is pending follow-up from the technical team.

You fixed me in 30 seconds!

Thank you

P.S. Now I have a problem with Extension Routes showing upgrade available for $39 when I had a license for it from before the upgrade. (It also says that a license is free on the activation page, so I stupidly paid to upgrade it before the upgrade process just to be told it is free afterwards, or $39 depending on which I am to believe).

False alarm, it did not fix.

CLI shows successful activation, but GUI does not, and all commercial modules are now no longer licensed…

Well you are a step closer. You can make an “eth0” interface to tie your activation to if your server doesn’t have one, using those ip link commands. You would just need to make sure that dummy interface gets created on each boot.

If you have an

/etc/udev/rules.d/70-persistent-net.rules

you could rename the real physical one to ‘eth0’