14 to 15 Upgrade Tool Error

I have an up to date system and ran the 14 to 15 upgrade tool with the following error in red:

I have heard of other people being able to upgrade 14 to 15 this year, so I’m not sure what this error is about.

Does anyone have any ideas?

There is another report of this, but no idea what the cause is. Can you PM me your deployment ID?

I appreciate your help, but I cannot for the life of me figure out how to PM using this forum software. I tried to click around everywhere, including through your and my own profile, and looked at the FAQ.

Click here:
image

Then you’ll see this:

1 Like

I’m missing that button. See image:

missing%20pm

I presume that PMs are blocked for @mrosu as a brand new user. Not to worry, I got what I needed and I can see that OPs “System Type” in the portal shows as “OSS Other” as opposed to “OSS FreePBXDistro”. I’ve opened an internal ticket (FREEI-1055) to bring it to development’s attn.

1 Like

Thanks very much!

1 Like

Hi @mrosu New version upgrade module has been released which has fix for your reported issue.

Refer to 14 to 15 upgrade wiki for further details.

1 Like

Hi!

I have the same issue. I installed the last release (14.0.10) of the module and for me problem still happens.

Thank you!

The upgrade module resolved my issue by the way. Thank you very much.

I’m still having it… anyone could please give me a hand?

Thank you!

I have also problems with upgrade a FreePBX 14 to 15. Currently the error differs. I always getting:
Unable to connect to remote mirror servers

Any idea which server is not reachable because there is no log or info about what goes wrong.

That seems to be an issue with the mirror server.

Try again once it comes back online.

I am also experiencing an error with the upgrade tool

Running a plain version of FreePBX 14.0.13.23 and Asterisk 16.7 – not the distro

I have already installed the latest upgrade tool version 14.0.10 but also still get the error noted above and below

fwconsole ma downloadinstall versionupgrade --force

(only works when the repos are working :wink: )

Dicko – i was already on 14.0.10 – not sure how your post helps resolve the issue?

Can you explain further?

thanks

Well for a while the repos have not been working, Personally I had a similar problem, FreePBX was already >= 14 but the upgrade script still bitched (click on the red link) , . . . . forcing the upgrade made everything kosher again and the upgrade proceeded.

lucky for you – no same luck here?

Do i need to reboot asterisk or the server afterwards?

fwconsole ma downloadinstall versionupgrade --force
No repos specified, using: [standard,extended,unsupported] from last GUI settings

Downloading module ‘versionupgrade’
Processing versionupgrade
Downloading…
320726/320726 [============================] 100%
Finished downloading
Extracting…Done
Download completed in 0 seconds
Generating CSS…Done
Module versionupgrade version 14.0.9 successfully installed
Updating Hooks…Done
[[email protected]# fwconsole versionupgrade --check
±-------±-----------------------±-----------------------------------------------------------------+
| Status | Name | Description |
±-------±-----------------------±-----------------------------------------------------------------+
| O | Files ownership | Files under /var/www/html appear to be owned by the correct user |
| O | Asterisk 13 or higher | Your Asterisk version of 16.7.0 is supported |
| O | NodeJS 8.0.0 or higher | Your NodeJS Version of 8.17.0 is supported |
| O | SQL 5.5.52 or higher | Your SQL Version of 5.5.64 is supported |
| O | PHP 5.6 or higher | Your PHP Version of 5.6.40 is supported |
| X | FreePBX 14 | Currently we Dont support upgradation |
±-------±-----------------------±-----------------------------------------------------------------+
You may not proceed with the upgrade. Please see the errors above

FreePBX 14 | Currently we Dont support upgradation |

Likely a Sangoma appliance and not FreePBX per se

Nope – not an appliance – just a regular VM on Linode which i installed myself from scratch – Centos – Asterisk and FreePBX