FreePBX | Register | Issues | Wiki | Portal | Support

13 to 14 upgrade via CLI gives different result than via GUI


(Bobf At Duxsys) #1

In preparation for upgrading our production system from freePBX 13 to 14, I set up a virtual machine test system using the Asterisk Now 1013 iso distribution (which is what we used to set up our production system), updating it, and then restoring a backup from our production system to it. Then I took a snapshot of the virtual machine and set about doing an upgrade to AsteriskNow 14. Since I started from a VM snapshot, I had the luxury of trying the upgrade two different ways.

First I tried it via the GUI, using the Admin/13 to 14 upgrade tool. This pretty much worked without a hitch, and the resulting system appeared to be correct (it was not connected to our phones, so I really couldn’t fully check it out).

Then I came across a posting that said that a CLI upgrade was preferable. I did a CLI upgrade, but I had a couple of problems during the upgrade (I had to do an upgrade repair), and the resulting system wouldn’t start asterisk since the “secret” in the .conf file was wrong (I was able to correct that). The resulting freePBX GUI was almost entirely correct, but voicemail as a destination was missing.

Another curiosity is that the login screens of the two upgraded systems are different. The GUI-originated login has “AsteriskNow” as the banner, and the CLI upgrade has “freePBX”. (upload://6ad6UHwB0hF9v1y5KqJQZZueHHh.png) (upload://7ZfUjTOi0CK5krV8Pg2Cuu0XWLA.png) There’s also a slight difference in the kernel version string.

Why the differences? The GUI-initiated upgrade looks better.


(Bobf At Duxsys) #2

The most disconcerting problem during the upgrade occurred during the second boot phase. We got a number of bold red blocks with the message “Asterisk is not connected.” The first occurred after “Updating tables” followed by a long list of names. Accompanying the message was “In php-asmanager.php line 242:” Since this happened six or more times during the pages of logging, I am concerned that some necessary processing may not have occurred. Since, eventually when the GUI was running, we also got “cannot connect to asterisk” we realized that the secret (password) in manager.conf was wrong. When we fixed that the GUI error disappeared, but was any damage, i.e., upgrade failures, done?


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.