FreePBX | Register | Issues | Wiki | Portal | Support

127.0.0.1 tried to authenticate with nonexistent user 'cxpanel'


(Chris) #1

I did a fresh install from the latest Stable-5.211.65-15 with Asterisk 11 and I’m seeing this over and over, I’ve never seen this message before on any other install what is this?

== Connect attempt from '127.0.0.1' unable to authenticate
[2014-06-24 06:56:25] NOTICE[475]: manager.c:2613 authenticate: 127.0.0.1 tried to authenticate with nonexistent user 'cxpanel'
[2014-06-24 06:56:25] NOTICE[475]: manager.c:2650 authenticate: 127.0.0.1 failed to authenticate as 'cxpanel'
  == Connect attempt from '127.0.0.1' unable to authenticate
[2014-06-24 06:56:30] NOTICE[486]: manager.c:2613 authenticate: 127.0.0.1 tried to authenticate with nonexistent user 'cxpanel'
[2014-06-24 06:56:30] NOTICE[486]: manager.c:2650 authenticate: 127.0.0.1 failed to authenticate as 'cxpanel'

(Terry) #2

How weird, i am really new to all of this and have just had the same problem, I have tried both distributions from freepbx and on the asterisk now site and have the same issues. My softphones wont connect and I have no port listening on the server to 5060. Does your netstat tell you are listening on 5060 ?

(I posted the same for a similar question)


(Chris) #3

No same thing here, I’m not sure what is going on here. This would be about my 50th installation and I’ve never had these issues before. I’m not seeing masses of people posting here so I’m not thinking it’s a distribution issue but then again I’m not the only one apparently.


(TheJames) #4

Have you clicked the “Apply changes” Button?
@mwolf9


(Jose) #5

If you’re not planning on using isymphony, uninstall the module, then disable the service with:

chkconfig iSymphonyServerV3 off

Then restart asterisk and those errors should go away. Worked for me anyway.


#6

Thank you jbustos. Your command fixed my issue. I have to reboot the entire server to apply the setting.


(James Hein) #7

The proper solution for this is to go to Admin -> Module Admin

Make sure the Basic repo is selected and then click “Check Online”

Under the Settings Section you should see “Asterisk Manager Users”. Install it.

Then you should click on Settings and go to Asterisk Manager Users. If there’s a red button that appears at the top to ‘apply’ go ahead and do that now.

Next, after you’re in Settings -> Asterisk Manager Users over on the right is a user called cxpanel. You need to click on it, bring it up, change nothing, and click “submit changes” on the bottom. This will write the cxpanel user details in the proper config file.

This should solve the problem. Big thanks to [TK]D-Fender over in the #freepbx channel on freenode for taking the time to help me work out the issue.


(Martin Brule Jr.) #8

@heinj_98 I have this problem now and am going through the instructions you provided, however, “Asterisk Manager Users” doesn’t appear in the Module Admin list after checking for updates. This module is installed but I don’t see it as an option to update/disable/install/etc within the Module Admin. Thoughts?

My system is fine after I enable iSymphony (creates the cxpanel user) and then disable iSymphony again, but something later causes the cxpanel user to disappear (deleted) and then I start seeing the 127.0.0.1 failed to authenticate as ‘cxpanel’ messages on the asterisk CLI.

Thoughts?


#9

This is an old post, but I have created an issue for this. I ran into this problem today.

https://issues.freepbx.org/browse/FREEPBX-16859


(Itzik) #10

Also noticed that yesterday on one of our machines, had in mind to come back later… now i don’t remember which PBX that was. :face_with_raised_eyebrow:


(Jerry Riggin) #11

This still happens when you remove iSymphony completely from Module Admin in 10.13.66-22. You completely remove iSymphony from your system you also have to run

yum remove iSymphonyServerV3-fpbx

Then the tried-to-authenticate-with-nonexistent-user-cxpanel error goes away.