FreePBX | Register | Issues | Wiki | Portal | Support

10.13.66-22 Module Updates Fail and Currupt Userman [Doctrine\DBAL\DBALException]

configuration
bug
Tags: #<Tag:0x00007f749e8c9be0> #<Tag:0x00007f749e8c9938>

(Jerry Riggin) #1

I’m having this issue on a dev vm running in ESXi. I have to upgrade a few production systems at the 10.13.66-22 level which need many module updates and upgrade to SNG7. So I did a clean install on a VM and updated everything a few months ago, restored backups to it. I was aboout to do 13-14 upgrade on it today so did “fw console ma updateall” and it produced the following error many times.

[Doctrine\DBAL\DBALException]
Unknown database type bit requested, Doctrine\DBAL\Platforms\MySqlPlatform may not support it.

The first was after “Updating tables callerid_entries…”
It seems to have run through the Node update 4 times.

When it tried to update hooks after vmnotify successfully installed I got the error

 [Exception]
  Unable to locate the FreePBX BMO Class 'Userman'A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install userman 2) fwconsole ma enable userman

Now anytime I try a reload I get the Userman error. “fwconsole ma install userman” produces the DBAL database error, so I am kind of stuck.

I don’t want to start over and reinstall for fear I will just spend hours and wind up in same place.

I get nothing helpful googling the database error.

Has this happened to anyone else?


(system) closed #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.