*1 not working to record

I have FreePBX running in a VoxBox install. Under “General Settings”, “Asterisk Dial command options” is trWw and “Asterisk Outbound Dial command options” is “Ww”. I was able to record on Monday when I set this up - but now NOTHING.



All extensions are configured for recording on demand. Additionally, if I set inbound or outbound to always record, the wav files show up in /var/spool/asterisk/monitor. Asterisk is seeing keypresses since voicemail is working.

Bueller? Bueller?

Did you try trW and outbound W?

I’ve tried trW / W and trw / w and issued the *1 from both endpoints and still no recording on demand.

The thing that baffles me is that it worked when I initially set it up - and I don’t recall changing anything there. Is there some sort of codec dependency or something like that?


Is there any useful output from the CLI?

I have the same problem

no idea ???

I have seen this problem with some phones. The way that I solved was to go into the feature code tab and change the *1 to something else. I used 31 and it worked. It must have been something with the phone and the * key code.

You need to review the dial plan inside the phone. It has first crack at allowing or blocking the strings before they are forwarded on to asterisk and FreePBX. As EasyVoxBox stated sometimes to solve the problem you’ll need to change the string it looks for to one that the phone will allow through. (ata devices for example can use that as a feature code for the device and NOT pass it on to the system).

I had the caller try *2 to see if the in-call menu worked and it did.
I can hear a very short DTMF from the caller when dialing *1 and there is no response from the CLI.

From the *2, I could see I was placed on “Hold”

The “Record all calls” works. Just not *1.