1.87.210.57 Beta Release Versions

Below is a outline of the current FreePBX Beta distro and a link to all the upgrade scripts.

The current FreePBX Beta Distro is 1.87.210.57 series. This includes FreePBX 2.10, Centos 5.7 and Asterisk 1.8 and consist of the following releases.

[list]
[] 1.87.210.57-2- This upgrades your system to the latest Asterisk 1.8.7.1-1 which fixes the security vulnerability found in Asterisk. You can read up on this SIP Vulnerability at http://downloads.asterisk.org/pub/security/AST-2011-012.pdf
[
] 1.87.210.57-3- Upgrade to PHP 5.3. We had stayed on PHP 5.2 with Centos 5.7 tell now because FreePBX 2.10 is the first official version to support PHP 5.3
[*] 1.88.210.57-1- Upgrade to Asterisk 1.8.8.0-1 and all FreePBX 2.10 modules for lots of little fixes. This will also take you to the stable of 1.88.210.57-1
[/list]

Below is a list of upgrade scripts you can download and run to update your existing Beta system.

[list]
http://upgrades.freepbxdistro.org/beta/1.87.210.57/upgrade-1.87.210.57-1.sh
http://upgrades.freepbxdistro.org/beta/1.87.210.57/upgrade-1.87.210.57-2.sh
http://upgrades.freepbxdistro.org/beta/1.87.210.57/upgrade-1.87.210.57-3.sh
http://upgrades.freepbxdistro.org/beta/1.88.210.57/upgrade-1.88.210.57-1.sh
[/list]

You can check your current version by going to the sysadmin module or from the Linux CLI do a;

cat /etc/asterisk/freepbxdistro-version

All upgrades need to be installed in numeric ascending order.

I believe this has something to do with the php version, it seems that php is still at 5.2.17 and has not updated to 5.3.3. I have tried yum update php and the process seems to abort:

Transaction Summary

Install 0 Package(s)
Upgrade 10 Package(s)

Total size: 6.4 M
Is this ok [y/N]: Exiting on user Command
Complete!

I did not issue a user command when it exited and version of php has remained at 5.2.17.

Tony,

I just ran the script and now can’t get in to the GUI, seeing error 500 cannot load /admin/config.php, the Apache log shows this:

[Sat Nov 26 07:51:09 2011] [error] [client 10.20.20.100] PHP Fatal error: Incompatible file format: The encoded file has format major ID 65540, whereas the Optimizer expects 2 in /var/www/html/admin/modules/sysadmin/functions.inc/general.php on line 0, referer: http://172.16.90.10/admin/config.php

Could you give me some guidance please?

You should not have php 5.3 yet. We just started testing with it and will have update script this week that installs that and some other things. You must of done a yum update or something to get 5.3.

You need to update sysadmin and framework to the latest version that will work with php 5.3 and make sure you have uninstalled zend-optimizer and installed php-53-zend-guard instead.

I have a mostly working but still needs some testing -3 upgrade script that handles all this for you. You can download and try it out from http://upgrades.freepbxdistro.org/1.87.210.57/upgrade-1.87.210.57-3.sh

Tony

The new script has gone into an endless loop:

mkdir: cannot create directory /usr/tmp/sa4.32.6.2-7': File exists sh: line 56: /usr/sbin/amportal: No such file or directory sh: line 76: /usr/sbin/amportal: No such file or directory sh: line 420: /usr/sbin/amportal: No such file or directory chown: cannot access/opt/xactview/’: No such file or directory
cat: /etc/asterisk/pbx-version: No such file or directory

Tony,

I exited the loop and the GUI is back, will check if everything is working and let you know.

Stonet. Sorry I had a mistype in the script. I just published the latest. What you need to do is just a yum update on your system to make sure you have all the latest RPM’s. Also go edit your version file to match the -3 version.

Tony,

It looks to me as if the yum update did not work and exited before the update, it just happened, I did not intervene at the y/N prompt.

The good newss is thaat everything seems to be working as it should, will let you know if anything else shows up.

Thanks for your help. Below is what happened with the yum update:

[[email protected] ~]# yum update

Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
–> Running transaction check
—> Package apr-util.i386 0:1.3.12-1.w5 set to be updated
—> Package httpd.i386 0:2.2.19-1.w5 set to be updated
–> Processing Dependency: httpd-tools = 2.2.19-1.w5 for package: httpd
–> Processing Dependency: apr-util-ldap for package: httpd
–> Running transaction check
—> Package apr-util-ldap.i386 0:1.3.12-1.w5 set to be updated
—> Package httpd-tools.i386 0:2.2.19-1.w5 set to be updated
–> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size

Updating:
apr-util i386 1.3.12-1.w5 pbx-shared 86 k
httpd i386 2.2.19-1.w5 pbx-shared 1.1 M
Installing for dependencies:
apr-util-ldap i386 1.3.12-1.w5 pbx-shared 14 k
httpd-tools i386 2.2.19-1.w5 pbx-shared 71 k

Transaction Summary

Install 2 Package(s)
Upgrade 2 Package(s)

Total download size: 1.3 M
Is this ok [y/N]: Exiting on user Command
Complete!
[[email protected] ~]#

After update I get the following message -

Symlink from modules failed

retrieve_conf failed to sym link:
/etc/asterisk/chan_dahdi.conf from dahdiconfig/etc (Already exists, not a link)
This can result in FATAL failures to your PBX. If the target file exists and not identical, the symlink will not occur and you should rename the target file to allow the automatic sym link to occur and remove this error, unless this is an intentional customization.
Added 14 minutes ago

The Dahdi module is not support by FreePBX and we recommned not using it as it has lots of problems.

Thanks! But I didn’t (knowingly) install it. Just did the initial install from the beta ISO when it was first released, then ran the two .sh upgrades today.

Well we dont install that module with the ISO at all. We purposely exclude it.

Ok. Thanks. somewhere along the line it was added. I don’t recall adding any new modules and I don’t need that one so I don’t think I would have done it manually. I removed the module and the error is gone.

Previously I posted in 64bit discussion. I think it should of been posted here.
Hope I am not breaking protocol.

Dell PowerEdge 64bit dual processor
FreePBX 2.10.0beta2.5
Asterisk (Ver. 1.8.7.1):

Just installed aastra-scripts
handset logged in and authenticated okay - Still No Service

In the Asterisk Logfiles
[2011-12-01 08:39:46] NOTICE[4795] chan_sip.c: Registration from '“Richard” ’ failed for ‘192.168.1.100:5060’ - No matching peer found
[2011-12-01 08:39:46] NOTICE[4795] chan_sip.c: Registration from '“Richard” ’ failed for ‘192.168.1.100:5060’ - No matching peer found

Freepbx connections not showing extensions or trunk registrations

FreePBX framework was disabled in Module Admin
Downloaded installed enabled 2.10.0beta2.5
still no calls in or out?

What am I doing wrong?

Fresh load of 1.87.210.57-3 x64

Click Applications, Extensions, Generic SIP, Submit… Cannot display page. Tried IE and Firefox.

Many modules display without style/formatting.

I’m having this on a beta loaded 2 weeks ago, and a freshly loaded/freshly download x64 beta ISO.

Applications, Announcements… Page displays incorrectly.

Applications, Call Flow Control… Page displays incorrectly.

Applications, Callback… Page displays incorrectly.

Probably many more. Guessing it’s related to the new PHP version and some template/styling errors.

Enabling display errors for PHP shows the following on every FreePBX page:
Warning: date(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘America/Denver’ for ‘MST/-7.0/no DST’ instead in /var/www/html/admin/modules/sysadmin/functions.inc/licensed.php on line 0 Warning: date(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘America/Denver’ for ‘MST/-7.0/no DST’ instead in /var/www/html/admin/modules/sysadmin/functions.inc/licensed.php on line 0

All default installed modules, all updated.

Just learning this stuff, and am in a fully functioning environment, Did update last night , all is running fine , Elasitic Gui working fine, however cannot get to the unembedded pbx gui anylonger, Any help is appreciated… thanks

You can not use these upgrade scritps on anything but the FreePBX Distro. If you used them on eElastix you just broke the box.

Any ideas on my issue posted above Tony ?? Same issues on 2 different boxes from fresh load.