1.810.210.57-1 upgrade -- manager.c: tried to authenticate with nonexistent user 'aastra-xml'

Ran through the following 3 scripts to bring us up to the current release:


Made test calls and all seemed well, but I didn’t look at the CLI. The system appears to be functional, but the CLI is scrolling the following info:

[2012-03-22 07:32:02] NOTICE[21861]: manager.c:2369 authenticate: tried to authenticate with nonexistent user ‘aastra-xml’
[2012-03-22 07:32:02] NOTICE[21861]: manager.c:2406 authenticate: failed to authenticate as ‘aastra-xml’

Any tips as to where I might start would be appreciated. I’ve googled it here and on the web. I found similar issues, but nothing to help me get started.



Did you reboot the box. Looks like something changed with Aastra XML scripts for the manager. You could try restarting asterisk and the aastra xml daemons or just reboot the box.

This seems to have fixed the problem.

Thank you Tony!

yum reinstall aastra-xml-scripts

The is what I figured. I will try to look at the stupid aastra scripts again. On upgrade they are removing the settings in manager_custom.conf