0 hangs up in VM menus

I am using Asterisk 1.4.20

I went into the voicemail menu’s to change a password for a user… under mailbox options it says press 4 to change password… upon pressing 4 it asks to record a temporary greeting… after doing so, it does not ask to enter a new password and now when I log into voicemail it hangs up when I press 0 to get into mailbox options…

I also had VMX Locator enabled for this extension, but disabled it, unfortunately this did not fix my problem.

Here is the output of my asterisk console after I’ve entered the voicemail password and it finishes reading my 1st level menu options. I dial “0” and here’s what happens.

– <SIP/217-090e32b8> Playing ‘vm-helpexit’ (language ‘en’)
== Spawn extension (from-internal, *97, 106) exited non-zero on ‘SIP/217-090e32b8’
– Executing [h@from-internal:1] Macro(“SIP/217-090e32b8”, “hangupcall”) in new stack
– Executing [s@macro-hangupcall:1] ResetCDR(“SIP/217-090e32b8”, “w”) in new stack
– Executing [s@macro-hangupcall:2] NoCDR(“SIP/217-090e32b8”, “”) in new stack
– Executing [s@macro-hangupcall:3] GotoIf(“SIP/217-090e32b8”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [s@macro-hangupcall:6] GotoIf(“SIP/217-090e32b8”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [s@macro-hangupcall:9] GotoIf(“SIP/217-090e32b8”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [s@macro-hangupcall:11] Hangup(“SIP/217-090e32b8”, “”) in new stack

Take a look at the /etc/asterisk/voicemail.conf file at the bottom. Do you see a line for the extension? If so copy that line here please.

I’m guessing you will not which means it somehow lost the voicemail.conf line for that extension. You should be able to re-create it by editing the extension in the GUI and changing the setting for email address, email attachment, delete vmail, play envelope, etc. submit it, apply changes then go back and reset it to what you want it to be.

The other issue it could be is that it does not have proper rights to the folders (type the amportal chown command to fix that).

217 => 1234,Derek Grimes,attach=no|saycid=no|envelope=no|delete=no

ownerships of /var/spool/asterisk/* are correct…

I also tried changing some settings via FreePBX and changing them back to see if it fixed anything with no luck…

When I wanted to change my temp password it kept asking for a temporary message… after leaving one it disconnected and going back in to voicemail options by dialing 0 just hung up on me…

Asterisk created temp.gsm etc files in /var/spool/asterisk/default/ext#

rm /var/spool/asterisk/default/ext#/temp*
fixed my problem

To allow my users to change their vm passwords from the default I have given them a link to the ARI portal.